Showing off my tank...

Discussion in 'Aquatic related photos' started by sa-shooter, May 14, 2014.

  1. sa-shooter
    Offline

    sa-shooter Noob

    • APSA Member
    90%
    Joined:
    Sep 7, 2013
    Messages:
    52
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    Cape-Town
    So just posting a couple of pics, not as great as some of you guys but getting on slowly. Honestly, I wanted to get my Angel in the FOTM, cant find it so I assume its not a thing anymore. Have been focusing on my fish more than my plants as you can see :whip2:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]
     
  2. Chongkie
    Offline

    Chongkie Aquascaper

    • APSA Member
    23%
    Joined:
    Aug 15, 2013
    Messages:
    1,495
    Likes Received:
    712
    Trophy Points:
    123
    Location:
    Pietermaritzburg
    You got lots of fish in there... is that the only pump you are using?

    and that is a lot of moss. and what is that plant on the back right? reddish one?

    If i may suggest, try get plants like glosso, HG, etc... and plant in the substrate. You are wasting the awesome substrate without any plants in it. And maybe tie the moss to the rocks if you want, or add driftwood and tie the moss to it.
     
  3. sa-shooter
    Offline

    sa-shooter Noob

    • APSA Member
    90%
    Joined:
    Sep 7, 2013
    Messages:
    52
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    Cape-Town
    That is the only filter I have at the moment. The moss is tied to a rock in the front section. I lost all of my HC due to my CO2 freaking out on me and couldnt fix the cylinder valve. As for the 2 bags of aquasoil, yeah I know its a waste but I hope to get some nice plants soon enough. Gotta get rid of my pleco first. He is the one that dug up my HC
     
  4. AdrianT
    Offline

    AdrianT Aquascaper

    • APSA Member
    73%
    Joined:
    Jan 29, 2014
    Messages:
    1,804
    Likes Received:
    1,483
    Trophy Points:
    173
    Did you delete the pics? :(
     

Share This Page